Cisco Configuration Guide / Hints for reference

Cisco Configuration Guide / Hints for reference

Here is a reference configuration template for Cisco devices. to establish BGP session with Route-Server.

Please modify and apply it according to your specific requirements.

Multi-Lateral Peering detail:

Partner End details
IPv4 103.61.232.11/24
IPv6 2001:df1:d440:1::11/64
md5 password

 

EdgeNXT IX End details
Route server-1 IPv4 103.61.232.1
Route server-1 IPv6 2001:df1:d440:1::1
Route server-2 IPv4 103.61.232.2
Route server-2 IPv6 2001:df1:d440:1::2
ASN 150528

Configuration template for Customer (Cisco device):

# Interface Configuration

interface GE0/1
description EdgeNXT - Peering
ip address 103.61.232.11 255.255.255.0
ipv6 address 2001:df1:d440:1::11/64

no ip redirects ! Don't do redirects
no ip proxy-arp ! Don't run proxy ARP on your EdgeNXT interface no cdp enable ! Don't run CDP on your EdgeNXT interface
no ip directed-broadcast ! Directed broadcasts are evil. no mop enable ! Disable the DEC drek if you haven't done so globally yet.

duplex full
no keepalive ! L2 keepalives are useless on the EdgeNXT ipv6 nd suppress-ra ! or ipv6 nd ra suppress Based Cisco IOS or IOS-XR no ipv6 redirects ! Don't do redirects

!
# BGP Configuration
! REPLACE 65000 with your ASN.
router bgp 65000
bgp router-id X.X.X.X
bgp log-neighbor-changes
!

!
address-family ipv4
no bgp enforce-first-as
neighbor 103.61.232.1 description rs1.EdgeNXT
neighbor 103.61.232.1 remote-as 150528
neighbor 103.61.232.1 activate
neighbor 103.61.232.1 soft-reconfiguration inbound
neighbor 103.61.232.1 route-map EdgeNXT_OUT out
neighbor 103.61.232.2 description rs2.EdgeNXT
neighbor 103.61.232.2 remote-as 150528
neighbor 103.61.232.2 activate
neighbor 103.61.232.2 soft-reconfiguration inbound
neighbor 103.61.232.2 route-map EdgeNXT_OUT out

address-family ipv6
neighbor 2001:df1:d440:1::1 description rs1.ipv6.EdgeNXT
neighbor 2001:df1:d440:1::1 remote-as 150528
neighbor 2001:df1:d440:1::1 activate
neighbor 2001:df1:d440:1::1 soft-reconfiguration inbound
neighbor 2001:df1:d440:1::1 route-map EdgeNXT_IPv6_OUT out
neighbor 2001:df1:d440:1::2 description rs2.ipv6.EdgeNXT
neighbor 2001:df1:d440:1::2 remote-as 150528
neighbor 2001:df1:d440:1::2 activate
neighbor 2001:df1:d440:1::2 soft-reconfiguration inbound
neighbor 2001:df1:d440:1::2 route-map EdgeNXT_IPv6_OUT out
exit-address-family
!

# Create Prefix list for IPv4 and IPv6 (Add all prefixes)
Note: ISPs should announce only those routes/prefixes that belong to their ASN and minimum acceptable subnet is /24
!
ip prefix-list My_IPv4_Prefixes seq 10 permit 44.44.44.0/22
ip prefix-list My_IPv4_Prefixes seq 20 permit 55.55.55.0/24
!
ipv6 prefix-list My_IPv6_Prefixes seq 10 permit 2222:1234:1234::/48
ipv6 prefix-list My_IPv6_Prefixes seq 20 permit 2222:1234:1235::/64
!

! Route Map configuration
route-map EdgeNXT_OUT permit 10
match ip address prefix-list My_IPv4_Prefixes
!

route-map EdgeNXT_IPv6_OUT permit 10
match ipv6 address prefix-list My_IPv6_Prefixes
!
# Configure AS prepending on all other BGP sessions (Telcos/Uplinks)
# Optional, To influence incoming traffic and prioritize a peering link over another, you can use AS-path prepend. Simply prepend your ASN multiple times towards your Internet transit to make it less preferred. The longer AS-path will make the peering link more attractive. # Use your ASN in place of 65000
route-map TCL_OUT permit 10
match ip address prefix-list My_IPv4_Prefixes
set as-path prepend 65000 65000 65000
!
route-map TCL_OUT permit 10
match ip address prefix-list My_IPv6_Prefixes
set as-path prepend 65000 65000 65000